특별한 이유가 없으면 소프트웨어 업데이트는 항상 최신 버전을 깔아준다. 살다보면 최신 버전 말고 구 버전이 필요한 경우가 있다. 내 경우에는 firefox 8.0 에서는 오픈 뱅킹이 되지 않아 7.0 을 깔아야 했다. 그런 경우에는 다음과 같이 하면 된다.

$ sudo apt-get purge firefox
$ sudo apt-get install firefox=7.*

신고
posted by 신묘군
무슨 이유인지 원리까지는 모르겠는데 최신 버전의 publish sync (페이스북에서 글을 쓰면 구글+와 트위터에 동시에 게시되게 하는 기능. 물론 구글+나 트위터에서 쓰면 다른 두 곳에 올라가는 것도 당연히 된다.) 를 불여우 8.0에 설치하면 안된다고 튕긴다. 이런 경우에는 억지로 8.0에 설치될 수 있도록 설치 정보를 조작해주면 된다. 그 절차는 다음과 같다.

1. publish sync를 다운로드 받는다. (보통은 그냥 클릭하면 웹 브라우저에 바로 설치가 되는데 그렇게 하지 말고 마우스 오른쪽 버튼을 클릭하여 파일을 다운로드 받는다.)

2. 다운로드 받은 파일은 **.xpi 인데 이는 실은 zip 파일이다. 확장자를 zip 으로 변경하고 압축 푸는 프로그램으로 풀어준다.

3. 그럼 맨 위의 디렉토리에 install.rdf 라는 파일이 있다. 여기에

<em:maxVersion>???</em:maxVersion>

라고 되어 있는 부분을 찾아서 ??? 부분을 8.0 으로 강제로 바꾸어준다.

4. 전체를 다시 zip 으로 묶고 확장자를 xpi 로 바꾼다.

5. 불여우의 확장기능 화면으로 들어가서 파일로부터 설치 기능으로 xpi 파일을 설치하면 끝.
신고
posted by 신묘군
기술을 얘기한다 2008.01.02 18:18
이런 저런 이유로 며칠 전 부터 사용하는 조테로 (zotero, 이름이 좀 거시기 하지만 무지하게 훌륭한 프로그램이다. 관련한 소개는 --> 요기 클릭 <-- )  때문에 쓸데없는 고생을 하고 있다. 이 프로그램은 불여우(firefox, 파이어폭스) 플러그 인으로 동작하는데 기본 locale 설정을 불여우로부터 가져올 뿐 설정할 수 있는 별도의 인터페이스는 제공하지 않는다. 따라서, 나 처럼 한글판 불여우를 쓰는 사람은 무조건 조테로 메뉴도 한글판으로 써야 한다. 그런데 으례 그렇듯이 한글판 메뉴 번역이 틀리거나 어색하여 정확히 무슨 기능인지 알기 어려운 것도 있다. (오래 쓰고 나면 익숙해지겠지만 지금 당장이 문제다.) 그래서 하는 수 없이 불여우의 locale을 영어로 돌려야 한다. 방법은 간단하다.

주소창에서 about:config 라고 친 뒤 뭐가 너무 많이 나오므로 필터 창에서 locale이라고 입력해서 general.useragent.locale 이라는 설정 이름을 찾아서 ko 를 en 으로 바꿔주면 된다. 아직 충분히 테스트해보지 않았지만 다른 곳에 내가 한글로 나오기를 원하는 것이 영어로 나오는 곳이 있을거다. 그런 점에서 본다면 플러그 인의 언어 설정은 디폴트는 웹 브라우저에서 가져오되 추가로 변경 가능하게 하는 것이 올바른 가이드라인이 아닌가 싶다.
신고
posted by 신묘군